AMcTools Forum 
Pages: 1
Send Topic Print
VMLAB and STK500v2 (Read 3801 times)
YaBB Newbies

I Love VMLAB !

Posts: 1

VMLAB and STK500v2
03/25/11 at 00:31:25
Hi, is there any chance that the new release of vmlab will support the latest (or newer than 1.42) version of STK500 firmware ? I am trying to use the current vmlab with STK500.exe from AVR Studio ver. 4.18 (with SP3) but with no succes. I know STK is "oldfashioned" but there is very nice and powerful piece of software (which requires very simple hardware) done by Christian Urlich which could be used with vmlab in STK-compatible mode.
Best regards,
Back to top
  IP Logged
YaBB Administrator

I love forums, don't

Posts: 308
AMcTools (Spain)
Gender: male
Re: VMLAB and STK500v2
Reply #1 - 03/28/11 at 00:14:14

Well, the thing is that I cannot promise you that this will be supported and when. However I can give you some hints, if you wish to integrate the programmer or any other utility into VMLAB:

- The VMLAB STK500 interface just calls and reads back Atmel's original STK500.EXE, so it is fully string based. If you are able to write a program that in some why wraps the new STK500.EXE into the old text interface, in theory, it would work.

- There is a utility: the CLICKTOOL, which can integrate any software into VMLAB. Just use this in the project file:

[[font=Courier New]
.CLICKTOOL "myUtility.exe -a myFile.hex";  the command line....[/font]

Then VMLAB will call this when you click the "tools" buttons (the most top right).
Back to top
WWW   IP Logged
Pages: 1
Send Topic Print